The UK hub for Luscombe Aircraft across Europe 

  • Ignition harness

  • Technical Chat Tips and Advice, including flying the Luscombe
Technical Chat Tips and Advice, including flying the Luscombe

Moderator: HTB

 #9216  by Florian
 Mon Jul 04, 2016 8:03 am
Moin,

since mid May I have trouble with my engine. When I start it up I have a hard time keeping it running and a lot of misfiring. When I switch to left mag nothing changes and on the right mag it dies completely. I already changed the spark plugs and gave the mags to friend working in a repair station. They couldn't find anything wrong with them. After reinstalling the mags we checked the timing and it seems to be correct but the engine is still running badly. So I want to change the last thing I haven't so far. The ignition harness.

I have a Conti C85-12F with Slick mags. The left one is marked "M1755 LH" and the right one "M1745 RH". So far it seems to me that this is actually the harness part number and that both harnesses are different. I assume that this is a matter of cable length or so.When I look into this document at page 63 I assume that with part number M1780 I get both cables. Am I right? And the 30° given in that table, does it refer to ignition timing or what is it for?

With all that little issues I still really like that plane but I have to admit that it is a steep learning curve not only as pilot. I really start a hang of working on her but I still need to learn so much stuff.

I hope you can help me getting her back in the air right in time for Sywell.


Florian
 #9217  by Nige
 Mon Jul 04, 2016 2:43 pm
I hope so too Florian. Interesting..
I will chat to a couple of fellas about this.. There must be a way to test the harness? Also, can you get a serviceable mag to replace the faulty one? Then see what result you have. How old is the harness? They are expensive items to purchase to try out!

Nige.
 #9218  by Florian
 Mon Jul 04, 2016 4:18 pm
Hey Nige,

thanks for reply. I don't know where to get a mag at least faster than a harness. A pilot from our club offered me the mags from his overhauled engine but that is a 6 cylinder model. So I guess they won't fit. Anyway, my mags where on a teststand last week and were found in perfect working order.

About the age of the harness I have no documentation that it had been changed. So I assume that it is at least from 1985 where the engine got upgraded from a C65 to a C85. So it's probably time to change it.

Also I forgot to mention that with Aircraftspruce M1745 and M1755 are a little bit over 300€ and M1780 is about 500€. That would at lest fit my understanding of rebate if I buy to pieces in one box...


Florian
 #9219  by Nige
 Mon Jul 04, 2016 5:12 pm
Ah, ok Florian. Perhaps investment in new harnesses may be the way forward - your call? It's a pity you can't run the engine in the dark, as with my motorcycles and even old cars - a sure way to see where the electricity is disappearing! :shock:
Good luck and we look forward to seeing you and your new shiny harnesses at SYWELL! :sunny:

Nige.
 #9221  by Vic
 Tue Jul 05, 2016 7:07 pm
I had a misfire on one mag a couple of years ago if taken over 1500 rpm.

I had both mags serviced although they had tested ok. The mags were checked on a rig and set up all ok. A 'mega' tester was put on the HT leads to the caps and on one lead you could see a spark just inside the cap. the conductor had broken about 1/4" from the end of the lead. They cut a bit off and re-terminated it for me, good as new. I think he used a special tool to remake the end of the lead.
 #9222  by Florian
 Tue Jul 05, 2016 7:44 pm
This afternoon I got a reply from Aircraftspruce. M1780 does include both M1755 and M1745. So I orderd that. If the harness arrives I'll keep you posted.
 #9226  by PeterB
 Sun Jul 10, 2016 1:20 am
I went through may of the same steps as you in the acquisition of my Luscombe. After changing plugs and sorting out the magnetos, my C90 still did not run well. A new harness made a world of difference.

I have a HT lead testing machine if anyone ever needs one. three out of eight leads in my original harness had voltage leakage.

The other thing that gets neglected on the small Continental engines is Carburettors. People seem to think they go on forever but in practice, just like anything else they wear out. I replaced mine and it paid for itself in a couple of years in terms of reduced fuel consumption. Not to mention better starting...
 #9228  by Keith Old
 Sun Jul 10, 2016 1:41 pm
Yes with Steve on that . Carbs can be fiddly am sure we would be interested as to your source
Keith GBSSA
 #9229  by Florian
 Sun Jul 10, 2016 3:57 pm
I hope the new harness will bring it. I thought about the carb, too, but I don't think it is causing the trouble because I have much more problems on the right mag then on the left. And with fuel consumption, I fly between 15 and 18 liters. Not to bad for an engine where the manufacturer says 30+.